<!DOCTYPE html><!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]--><!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]--><!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]--><!--[if gt IE 8]><!--><html class="no-js"><!--<![endif]--><head profile="http://gmpg.org/xfn/11"><meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script>
<script>var __sellerid="7c36422bef410beefa07c28a901d5e59";</script>
<link rel='preload' as='script' href='//securepubads.g.doubleclick.net/tag/js/gpt.js'>
<link href="//ad.doubleclick.net" rel="dns-prefetch">
<link href="//pagead2.googlesyndication.com" rel="dns-prefetch">
<link href="//googleads.g.doubleclick.net" rel="dns-prefetch">
<link href="//tpc.googlesyndication.com" rel="dns-prefetch">
<link href="//adservice.google.com" rel="dns-prefetch">
<link href="//secureads.g.doubleclick.net" rel="dns-prefetch">
<link href="//www.googletagservices.com" rel="dns-prefetch">
<link rel='preload' as='script' href='//go.ezodn.com/hb/dall.js?b=amx,appnexus,conversant,gumgum,ix,medianet,oftmedia,oneVideo,onetag,rubicon,undertone&cb=194-4-22'>
<script async="" src="//c.amazon-adsystem.com/aax2/apstag.js"></script>
<script data-cfasync="false" type="text/javascript" data-pagespeed-no-defer>var __ezaps=[{"slotID":"div-gpt-ad-gerweck_net-medrectangle-4-0","slotName":"/1254144/gerweck_net-medrectangle-4","sizes":[[300,250]]},{"slotID":"div-gpt-ad-gerweck_net-medrectangle-3-0","slotName":"/1254144/gerweck_net-medrectangle-3","sizes":[[728,90]]},{"slotID":"div-gpt-ad-gerweck_net-medrectangle-2-0","slotName":"/1254144/gerweck_net-medrectangle-2","sizes":[[728,90]]},{"slotID":"div-gpt-ad-gerweck_net-leader-1-0","slotName":"/1254144/gerweck_net-leader-1","sizes":[[728,90]]},{"slotID":"div-gpt-ad-gerweck_net-box-3-0","slotName":"/1254144/gerweck_net-box-3","sizes":[[728,90]]},{"slotID":"div-gpt-ad-gerweck_net-large-leaderboard-1-0","slotName":"/1254144/gerweck_net-large-leaderboard-1","sizes":[[300,250]]},{"slotID":"div-gpt-ad-gerweck_net-large-leaderboard-1-0_1","slotName":"/1254144/gerweck_net-large-leaderboard-1","sizes":[[300,250]]},{"slotID":"div-gpt-ad-gerweck_net-large-leaderboard-1-0_2","slotName":"/1254144/gerweck_net-large-leaderboard-1","sizes":[[300,250]]},{"slotID":"div-gpt-ad-gerweck_net-large-leaderboard-1-0_3","slotName":"/1254144/gerweck_net-large-leaderboard-1","sizes":[[300,250]]},{"slotID":"div-gpt-ad-gerweck_net-box-2-0","slotName":"/1254144/gerweck_net-box-2","sizes":[[300,250]]},{"slotID":"div-gpt-ad-gerweck_net-banner-2-0","slotName":"/1254144/gerweck_net-banner-2","sizes":[[336,280],[300,250]]}];var __ezapid="aa05931b-5308-4ea3-95a2-adf84f4ffde4";!function(a9,a){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}
a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};}("apstag",window);apstag.init({pubID:__ezapid,adServer:'googletag',schain:{complete:1,ver:'1.0',nodes:[{asi:'ezoic.ai',sid:__sellerid,hp:1}]}});function ezapsFetchBids(amazonSlots){if(typeof amazonSlots==='undefined'||amazonSlots.length===0){return}
apstag.fetchBids({slots:amazonSlots,timeout:2e3},function(bids){function getSlotById(id){if(typeof window.ezslots==='undefined'||window.ezslots==0){return;}
for(var i=0;i<window.ezslots.length;i++){var slot=window[ezslots[i]];if(typeof slot==='undefined'){continue;}
var slotId=slot.getSlotElementId();if(typeof slotId!=='undefined'&&slotId==id){return slot;}}}
function setA9DisplayBids(bids){if(typeof bids==='undefined'||bids.length==0){return;}
var keys=apstag.targetingKeys();for(var i=0;i<bids.length;i++){var bid=bids[i];for(var k=0;k<keys.length;k++){if(keys[k]in bid){ezSetSlotTargeting(bid.slotID,keys[k],bid[keys[k]]);}}}}
googletag.cmd.push(function(){setA9DisplayBids(bids);});});}
if(typeof __tcfapi!="undefined"){}else{ezapsFetchBids(__ezaps);}</script>
<script type="text/javascript">
	var __banger_pmp_deals=function(){var d={17:{"DealId":17,"Floor":160},18:{"DealId":18,"Floor":25},19:{"DealId":19,"Floor":100},7:{"DealId":7,"Floor":150},8:{"DealId":8,"Floor":200},916:{"DealId":916,"Floor":95},915:{"DealId":915,"Floor":150},874:{"DealId":874,"Floor":200},835:{"DealId":835,"Floor":200},20:{"DealId":20,"Floor":300},9:{"DealId":9,"Floor":300},10:{"DealId":10,"Floor":400},11:{"DealId":11,"Floor":500},12:{"DealId":12,"Floor":600},13:{"DealId":13,"Floor":700},14:{"DealId":14,"Floor":800}};return[{"SlotName":"/1254144/gerweck_net-banner-2","Deals":[d[17],d[18],d[19],d[7],d[8],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-medrectangle-2","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[10],d[11],d[12],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-leader-1","Deals":[d[17],d[18],d[19],d[7],d[8],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-medrectangle-4","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[10],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-box-3","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[10],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-medrectangle-3","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-large-leaderboard-1","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[10],d[11],d[12],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-box-1","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-large-leaderboard-1","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[10],d[11],d[12],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-box-1","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-large-leaderboard-1","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[10],d[11],d[12],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-box-1","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-large-leaderboard-1","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[10],d[11],d[12],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-box-1","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144/gerweck_net-box-2","Deals":[d[17],d[18],d[19],d[20],d[7],d[8],d[9],d[10],d[11],d[916],d[915],d[874],d[835]]}]}();
</script>
<script type='text/javascript'>_ebcids=[138231308856,138231308940,138231308949,138231387842,138231421744,138231421759,138231421774,138231421783,138231421789,138231421792,138242067587,138242067590,138242067602,138242067605,138242067608,138242067614,138242229406,138242229415,138242229421,138242229430];</script>
<script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>ezobv=19;</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>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</script><script type='text/javascript' data-ezscrex="false">var ezorbf = []; </script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>window.isEZABL=false;window.ezmadspc=300;window.ezoViewCheck=false;</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>window.ezDisableInitialLoad=false;</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>window.googletag=window.googletag||{};googletag.cmd=googletag.cmd||[];</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>(function(){var gads=document.createElement('script');gads.async=true;gads.type='text/javascript';var useSSL='https:'==document.location.protocol;gads.src=(useSSL?'https:':'http:')+
'//securepubads.g.doubleclick.net/tag/js/gpt.js';var node=document.getElementsByTagName('script')[0];node.parentNode.insertBefore(gads,node);})();</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>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</script>
<script type="text/javascript">(function(){function storageAvailable(type){var storage;try{storage=window[type];var x='__storage_test__';storage.setItem(x,x);storage.removeItem(x);return true;}
catch(e){return e instanceof DOMException&&(e.code===22||e.code===1014||e.name==='QuotaExceededError'||e.name==='NS_ERROR_DOM_QUOTA_REACHED')&&(storage&&storage.length!==0);}}
function remove_ama_config(){if(storageAvailable('localStorage')){localStorage.removeItem("google_ama_config");}}
remove_ama_config()})()</script>
<script data-ezscrex="false" data-cfasync="false">__ez.ssaf=[];__ez.sswp=4;__ez.ssv=1897;__ez.sshsdef=false;</script>
<script type="text/javascript">var ezoicTestActive = true</script>
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">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</script><script data-ezscrex="false" data-cfasync="false" type="text/javascript">var ezWp = true;</script><script data-ezscrex="false" data-pagespeed-no-defer data-cfasync="false" type="text/javascript">__ez.queue.addFile('banger.js', '//g.ezoic.net/porpoiseant/banger.js?cb=194-4&bv=19&v=51&PageSpeed=off', true, [], true, false, false, true);</script>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.vep=(function(){var pixels=[],pxURL="/detroitchicago/grapefruit.gif";function AddPixel(vID,pixelData){if(__ez.dot.isDefined(vID)&&__ez.dot.isValid(pixelData)){pixels.push({type:'video',video_impression_id:vID,domain_id:__ez.dot.getDID(),t_epoch:__ez.dot.getEpoch(0),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender"){return;}
if(__ez.dot.isDefined(pixels)&&pixels.length>0){while(pixels.length>0){var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&v="+btoa(JSON.stringify(pushPixels));__ez.dot.Fire(pixelURL);}}
pixels=[];}
return{Add:AddPixel,Fire:Fire};})();</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();</script>
	
	<title>  Booker T Discusses WWE Releasing Braun Strowman - Gerweck.net</title>
	
	<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
	<meta name="generator" content="WordPress 5.7.2"/>
	<meta name="viewport" content="initial-scale=1.0,width=device-width,user-scalable=0"/>
	
	<link rel="shortcut icon" type="image/ico" href="https://www.gerweck.net/wp-content/themes/gerweckv4/favicon.ico"/>

	<!-- Fonts -->
	<link href="https://fonts.googleapis.com/css?family=Raleway:400,600,800,900|Roboto:400,400italic,700" rel="stylesheet"/>
	
	<!-- Stylesheets -->
	<link rel="stylesheet" href="https://www.gerweck.net/wp-content/themes/gerweckv4/style.css?ff=1&amp;v3=&amp;wps=false" type="text/css" media="screen"/>
	
	<!-- RSS Definition -->
	<link rel="alternate" type="application/rss+xml" title="Gerweck.net RSS Feed" href="http://feeds.feedburner.com/gerwecknet"/>

	
	<meta name="robots" content="max-image-preview:large"/>
<link rel="dns-prefetch" href="//s.w.org"/>
<link rel="dns-prefetch" href="//c0.wp.com"/>
<link rel="alternate" type="application/rss+xml" title="Gerweck.net » Booker T Discusses WWE Releasing Braun Strowman Comments Feed" href="https://www.gerweck.net/2021/06/06/booker-t-discusses-wwe-releasing-braun-strowman/feed/"/>
 
    <meta property="og:title" content="Booker T Discusses WWE Releasing Braun Strowman"/>
    <meta property="og:description" content="Pro Wrestling Since 1997"/>
    <meta property="og:type" content="article"/>
    <meta property="og:url" content="https://www.gerweck.net/2021/06/06/booker-t-discusses-wwe-releasing-braun-strowman/"/>
    <meta property="og:site_name" content="Gerweck.net"/>
    <meta property="og:image" content="https://www.gerweck.net/wp-content/uploads/2015/12/braun-strowman-19.jpg"/>
 
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.gerweck.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="stylesheet" id="wp-block-library-css" href="https://c0.wp.com/c/5.7.2/wp-includes/css/dist/block-library/style.min.css" type="text/css" media="all"/>
<style id="wp-block-library-inline-css" type="text/css">
.has-text-align-justify{text-align:justify;}
</style>
<link rel="stylesheet" id="wp-polls-css" href="https://www.gerweck.net/wp-content/plugins/wp-polls/polls-css.css?ff=1&amp;ver=2.75.6&amp;wps=false" type="text/css" media="all"/>
<style id="wp-polls-inline-css" type="text/css">
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background: #000000;
	border: 1px solid #ffffff;
}

</style>
<link rel="stylesheet" id="jetpack_css-css" href="https://c0.wp.com/p/jetpack/9.8/css/jetpack.css" type="text/css" media="all"/>
<script type="text/javascript" src="https://c0.wp.com/c/5.7.2/wp-includes/js/jquery/jquery.min.js" id="jquery-core-js"></script>
<script type="text/javascript" src="https://c0.wp.com/c/5.7.2/wp-includes/js/jquery/jquery-migrate.min.js" id="jquery-migrate-js"></script>
<link rel="https://api.w.org/" href="https://www.gerweck.net/wp-json/"/><link rel="alternate" type="application/json" href="https://www.gerweck.net/wp-json/wp/v2/posts/493824"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.gerweck.net/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.gerweck.net/wp-includes/wlwmanifest.xml"/> 
<link rel="canonical" href="https://www.gerweck.net/2021/06/06/booker-t-discusses-wwe-releasing-braun-strowman/"/>
<link rel="shortlink" href="https://www.gerweck.net/?p=493824"/>
<link rel="alternate" type="application/json+oembed" href="https://www.gerweck.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.gerweck.net%2F2021%2F06%2F06%2Fbooker-t-discusses-wwe-releasing-braun-strowman%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://www.gerweck.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.gerweck.net%2F2021%2F06%2F06%2Fbooker-t-discusses-wwe-releasing-braun-strowman%2F&amp;format=xml"/>
<script type="text/javascript">
	window._wp_rp_static_base_url = 'https://wprp.zemanta.com/static/';
	window._wp_rp_wp_ajax_url = "https://www.gerweck.net/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '493824';
	window._wp_rp_num_rel_posts = '5';
	window._wp_rp_thumbnails = false;
	window._wp_rp_post_title = 'Booker+T+Discusses+WWE+Releasing+Braun+Strowman';
	window._wp_rp_post_tags = ['opinions', 'news', 'podcast', 'santana', 'braun', 'busi', 'rumor', 'wwe', 'throwback', 'hall', 'rubi', 'booker', 'black', 'garrett', 'releas', 'lana', 'murphi'];
	window._wp_rp_promoted_content = true;
</script>
<link rel="stylesheet" href="https://www.gerweck.net/wp-content/plugins/wp-page-numbers/gerweck/wp-page-numbers.css?ff=1&amp;wps=false" type="text/css" media="screen"/><style type="text/css">img#wpstats{display:none}</style>
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article"/>
<meta property="og:title" content="Booker T Discusses WWE Releasing Braun Strowman"/>
<meta property="og:url" content="https://www.gerweck.net/2021/06/06/booker-t-discusses-wwe-releasing-braun-strowman/"/>
<meta property="og:description" content="Booker T spoke on the latest episode of the Hall of Fame Podcast about a wide range of topics. Braun Strowman, Aleister Black, Lana, Ruby Riott, Buddy Murphy, and Santana Garrett ended up being rel…"/>
<meta property="article:published_time" content="2021-06-06T14:53:00+00:00"/>
<meta property="article:modified_time" content="2021-06-06T22:27:10+00:00"/>
<meta property="og:site_name" content="Gerweck.net"/>
<meta property="og:image" content="https://www.gerweck.net/wp-content/uploads/2015/12/braun-strowman-19.jpg"/>
<meta property="og:image:width" content="600"/>
<meta property="og:image:height" content="592"/>
<meta property="og:locale" content="en_US"/>
<meta name="twitter:creator" content="@gerweck"/>
<meta name="twitter:site" content="@gerweck"/>
<meta name="twitter:text:title" content="Booker T Discusses WWE Releasing Braun Strowman"/>
<meta name="twitter:image" content="https://www.gerweck.net/wp-content/uploads/2015/12/braun-strowman-19.jpg?w=640"/>
<meta name="twitter:card" content="summary_large_image"/>

<!-- End Jetpack Open Graph Tags -->
	
	<!-- Javascript Include (non crutial includes belong in the footer) -->
    <script src="https://www.gerweck.net/wp-content/themes/gerweckv4/js/vendor/modernizr-2.6.2.min.js"></script>
    
    <script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	

<style>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</style><script type="text/javascript">var ezouid = "1";</script><base href="https://www.gerweck.net/2021/06/06/booker-t-discusses-wwe-releasing-braun-strowman/"><script type='text/javascript'>
var ezoTemplate = 'pub_site';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 81851;
var ezdomain = 'gerweck.net';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex='false' data-cfasync='false' type='text/javascript' style='display:none' defer>
__ez.queue.addFile('__ezf_ezosuigeneris', '//g.ezoic.net/ezosuigeneris.js', true, [], true, false, false, false);
var __ez_ezosuigenerisEvt = function() { if(typeof(ezosuigeneris) != 'undefined'){__ez.bit.AddAndFire(_ezaq['page_view_id'], [(new __ezDotData('universal_user_id', ezosuigeneris))]); }};
__ez.queue.addFunc('__ez_ezosuigenerisEvt', '__ez_ezosuigenerisEvt', null, false, ['__ezf_ezosuigeneris','/detroitchicago/minneapolis.js','/detroitchicago/memphis.js'], false, false, false, false);</script><script data-ezscrex='false' data-cfasync='false' type='text/javascript' style='display:none' defer>__ez.queue.addFile('__ezf_ezosuigenerisc', '//g.ezoic.net/ezosuigenerisc.js?nogen=1', true, ["/detroitchicago/boise.js"], true, false, false, false);</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_81851=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["94391528-f9ce-4f28-7c56-cee5025221d4", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script>
<script type="text/javascript">var _audins_dom="gerweck_net",_audins_did=81851;__ez.queue.addFile('/detroitchicago/cmb.js', '//g.ezoic.net/detroitchicago/cmb.js?gcb=194-4&cb=&01&00&03&04&0d&06&07&0a&0c&0e&12&14&18&23&25&26&01-100-303-1004-10d-506-507-70a-30c-30e-212-414-318-1223-125-2126-19&cmbcb=14', true, [], true, false, true, false);</script></head>

<body class=""><span id="ezoic-pub-ad-placeholder-109" class="ezoic-adpicker-ad"></span><span class="ezoic-ad box-2 box-2109 adtester-container adtester-container-109" data-ez-name="gerweck_net-box-2"><span id="div-gpt-ad-gerweck_net-box-2-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-box-2-0')};</script></span></span>

	<header class="container">
		<div class="row">
			<div class="col-sm-12 col-md-2 logo">
				<a href="/" class="hide-text">Gerweck.net</a>
				<span class="icon-menu menu-btn js-menu-toggle"></span>
			</div>
			<div class="col-sm-12 col-md-8">
				<div class="menu-main-nav-container"><ul id="menu-main-nav" class="menu"><li id="menu-item-281379" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-281379"><a href="http://www.gerweck.net/">Top News</a></li>
<li id="menu-item-22164" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-22164"><a href="https://www.gerweck.net/tv-ratings/">Ratings</a>
<ul class="sub-menu">
	<li id="menu-item-64261" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64261"><a href="https://www.gerweck.net/tv-ratings/2012-tv-ratings/">2012</a></li>
	<li id="menu-item-135229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135229"><a href="https://www.gerweck.net/tv-ratings/2013-ratings/">2013</a></li>
	<li id="menu-item-280990" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-280990"><a href="https://www.gerweck.net/tv-ratings/2014-ratings/">2014</a></li>
	<li id="menu-item-280991" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-280991"><a href="https://www.gerweck.net/tv-ratings/2015-tv-ratings/">2015</a></li>
	<li id="menu-item-280992" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-280992"><a href="https://www.gerweck.net/tv-ratings/2016-tv-ratings/">2016</a></li>
	<li id="menu-item-306667" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-306667"><a href="https://www.gerweck.net/tv-ratings/2017-tv-ratings/">2017</a></li>
	<li id="menu-item-346769" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346769"><a href="https://www.gerweck.net/tv-ratings/2018-tv-ratings/">2018</a></li>
	<li id="menu-item-379299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-379299"><a href="https://www.gerweck.net/tv-ratings/2019-tv-ratings/">2019</a></li>
	<li id="menu-item-428674" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-428674"><a href="https://www.gerweck.net/tv-ratings/2020-tv-rating/">2020</a></li>
	<li id="menu-item-475278" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-475278"><a href="https://www.gerweck.net/tv-ratings/2021-tv-ratings/">2021</a></li>
	<li id="menu-item-281390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-281390"><a href="https://www.gerweck.net/tv-ratings/">View All</a></li>
</ul>
</li>
<li id="menu-item-2858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2858"><a href="https://www.gerweck.net/hall-of-fame/">Hall of Fame</a>
<ul class="sub-menu">
	<li id="menu-item-67565" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67565"><a href="https://www.gerweck.net/hall-of-fame/2012-inductions/">2012 Inductions</a></li>
	<li id="menu-item-149591" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149591"><a href="https://www.gerweck.net/hall-of-fame/2013-inductions/">2013 Inductions</a></li>
	<li id="menu-item-280987" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-280987"><a href="https://www.gerweck.net/hall-of-fame/2014-inductions/">2014 Inductions</a></li>
	<li id="menu-item-280988" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-280988"><a href="https://www.gerweck.net/hall-of-fame/2015-inductions/">2015 Inductions</a></li>
	<li id="menu-item-280989" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-280989"><a href="https://www.gerweck.net/hall-of-fame/2016-inductions/">2016 Inductions</a></li>
	<li id="menu-item-308454" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-308454"><a href="https://www.gerweck.net/hall-of-fame/2017-inductions/">2017 Inductions</a></li>
	<li id="menu-item-349414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-349414"><a href="https://www.gerweck.net/hall-of-fame/2018-inductions/">2018 Inductions</a></li>
	<li id="menu-item-381949" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-381949"><a href="https://www.gerweck.net/hall-of-fame/2019-inductions/">2019 Inductions</a></li>
	<li id="menu-item-430004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-430004"><a href="https://www.gerweck.net/hall-of-fame/2020-inductions/">2020 Inductions</a></li>
	<li id="menu-item-483141" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-483141"><a href="https://www.gerweck.net/hall-of-fame/2021-inductions/">2021 Inductions</a></li>
	<li id="menu-item-2863" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2863"><a href="https://www.gerweck.net/hall-of-fame/webmaster-inductions/">Webmaster Inductions</a></li>
	<li id="menu-item-281389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-281389"><a href="https://www.gerweck.net/hall-of-fame/">View All</a></li>
	<li id="menu-item-392984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-392984"><a href="https://www.gerweck.net/hall-of-fame/not-voted-in/">Not Voted In</a></li>
</ul>
</li>
<li id="menu-item-22526" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-22526"><a href="https://www.gerweck.net/pay-per-view/">PPV</a>
<ul class="sub-menu">
	<li id="menu-item-411675" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-411675"><a href="https://www.gerweck.net/pay-per-view/aew-results/">AEW Results</a></li>
	<li id="menu-item-22527" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22527"><a href="https://www.gerweck.net/pay-per-view/ecw-results/">ECW Results</a></li>
	<li id="menu-item-44673" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44673"><a href="https://www.gerweck.net/pay-per-view/roh-results/">ROH Results</a></li>
	<li id="menu-item-22528" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22528"><a href="https://www.gerweck.net/pay-per-view/tna-results/">TNA/Impact Wrestling Results</a></li>
	<li id="menu-item-22529" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22529"><a href="https://www.gerweck.net/pay-per-view/wcw-results/">WCW Results</a></li>
	<li id="menu-item-24208" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24208"><a href="https://www.gerweck.net/pay-per-view/wwe/">WWE Results</a></li>
</ul>
</li>
<li id="menu-item-2857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2857"><a href="https://www.gerweck.net/awards/">Awards</a>
<ul class="sub-menu">
	<li id="menu-item-62684" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62684"><a href="https://www.gerweck.net/awards/2011-awards/">2011 Awards</a></li>
	<li id="menu-item-133792" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-133792"><a href="https://www.gerweck.net/awards/2012-awards/">2012 Awards</a></li>
	<li id="menu-item-280984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-280984"><a href="https://www.gerweck.net/awards/2013-awards/">2013 Awards</a></li>
	<li id="menu-item-280985" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-280985"><a href="https://www.gerweck.net/awards/2014-awards/">2014 Awards</a></li>
	<li id="menu-item-280986" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-280986"><a href="https://www.gerweck.net/awards/2015-awards/">2015 Awards</a></li>
	<li id="menu-item-305238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-305238"><a href="https://www.gerweck.net/awards/2016-awards/">2016 Awards</a></li>
	<li id="menu-item-344844" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-344844"><a href="https://www.gerweck.net/awards/2017-awards/">2017 Awards</a></li>
	<li id="menu-item-377735" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-377735"><a href="https://www.gerweck.net/awards/2018-awards/">2018 Awards</a></li>
	<li id="menu-item-427320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-427320"><a href="https://www.gerweck.net/awards/2019-awards/">2019 Awards</a></li>
	<li id="menu-item-473256" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-473256"><a href="https://www.gerweck.net/awards/2020-awards/">2020 Awards</a></li>
	<li id="menu-item-281388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-281388"><a href="https://www.gerweck.net/awards/">View All</a></li>
</ul>
</li>
<li id="menu-item-281380" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-281380"><a href="#">Rosters</a>
<ul class="sub-menu">
	<li id="menu-item-378528" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-378528"><a href="https://www.gerweck.net/all-elite-wrestling/">All Elite Wrestling</a></li>
	<li id="menu-item-281385" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-281385"><a href="https://www.gerweck.net/deceased-wrestlers/">Deceased Wrestlers</a></li>
	<li id="menu-item-350292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-350292"><a href="https://www.gerweck.net/ecw-alumni/">ECW Alumni</a></li>
	<li id="menu-item-281386" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-281386"><a href="https://www.gerweck.net/females/">Females</a></li>
	<li id="menu-item-281384" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-281384"><a href="https://www.gerweck.net/roh-rosterfree-agents/">Free Agents</a></li>
	<li id="menu-item-281381" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-281381"><a href="https://www.gerweck.net/tna-talent-roster/">Impact Wrestling</a></li>
	<li id="menu-item-424009" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-424009"><a href="https://www.gerweck.net/mlw/">MLW</a></li>
	<li id="menu-item-463022" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-463022"><a href="https://www.gerweck.net/njpw/">NJPW</a></li>
	<li id="menu-item-419887" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-419887"><a href="https://www.gerweck.net/nwa/">NWA</a></li>
	<li id="menu-item-281383" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-281383"><a href="https://www.gerweck.net/nxt-2/">NXT</a></li>
	<li id="menu-item-433331" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-433331"><a href="https://www.gerweck.net/nxt-uk/">NXT UK</a></li>
	<li id="menu-item-338403" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-338403"><a href="https://www.gerweck.net/wwe-backstage-personnel/">Other WWE Personnel</a></li>
	<li id="menu-item-335168" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335168"><a href="https://www.gerweck.net/raw/">Raw</a></li>
	<li id="menu-item-349652" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-349652"><a href="https://www.gerweck.net/ring-of-honor/">Ring of Honor</a></li>
	<li id="menu-item-335419" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-335419"><a href="https://www.gerweck.net/smackdown/">Smackdown</a></li>
	<li id="menu-item-352795" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-352795"><a href="https://www.gerweck.net/wcw-alumni/">WCW Alumni</a></li>
	<li id="menu-item-281387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-281387"><a href="https://www.gerweck.net/wwe-hall-of-fame/">WWE Hall of Fame</a></li>
</ul>
</li>
<li id="menu-item-2859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2859"><a href="https://www.gerweck.net/information/">Misc</a>
<ul class="sub-menu">
	<li id="menu-item-281378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-281378"><a href="https://www.gerweck.net/contact-us/">Contact Us</a></li>
	<li id="menu-item-350371" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-350371"><a href="https://www.gerweck.net/information/march-madness-tournaments/">March Madness Tournaments</a></li>
	<li id="menu-item-310607" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-310607"><a href="https://www.gerweck.net/pay-per-view/royal-rumble-winners/">Royal Rumble Winners</a></li>
</ul>
</li>
<li id="menu-item-401410" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-401410"><a href="https://www.gerweck.net/2017-gerweck-report-podcasts/">GRP</a>
<ul class="sub-menu">
	<li id="menu-item-401413" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-401413"><a href="https://www.gerweck.net/gerweck-report-podcast/">Gerweck Report Podcast</a></li>
	<li id="menu-item-401414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-401414"><a href="https://www.gerweck.net/2014-gerweck-report-podcasts/">2014 GRP Podcasts</a></li>
	<li id="menu-item-401415" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-401415"><a href="https://www.gerweck.net/2015-gerweck-report-podcasts/">2015 GRP Podcasts</a></li>
	<li id="menu-item-401411" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-401411"><a href="https://www.gerweck.net/2016-gerweck-report-podcasts/">2016 GRP Podcasts</a></li>
	<li id="menu-item-401412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-401412"><a href="https://www.gerweck.net/2017-gerweck-report-podcasts/">2017-19 GRP Podcasts</a></li>
</ul>
</li>
</ul></div>			</div>
			<div class="col-sm-12 col-md-2">
				<div class="social-bar">
					<a href="http://instagram.com/stevegerweck" class="social-bar__link"><span class="icon-instagram"></span></a>
					<a href="https://www.youtube.com/channel/UCPTf7HK2Tgz8MvhdSteoV3Q" class="social-bar__link"><span class="icon-youtube"></span></a>
					<a href="https://www.facebook.com/pages/GERWECKNET/102544249785530" class="social-bar__link"><span class="icon-facebook"></span></a>
					<a href="https://twitter.com/gerweck" class="social-bar__link"><span class="icon-twitter"></span></a>
					<a href="https://www.linkedin.com/in/steve-gerweck-b25307a0/" class="social-bar__link"><span class="icon-linkedin"></span></a>
					<a href="https://www.tumblr.com/blog/view/stevegerweck" class="social-bar__link"><span class="icon-tumblr"></span></a>
				</div>
			</div>
		</div>
	</header>
	
	<!-- Start Content -->
	<div class="container content">
<div class="row">
	<div class="col-sm-7 col-md-8">
		<div class="ad text-center hidden-md hidden-sm hidden-xs">
<div id="ezwrap_adsense_responsive_full_0"><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 468 -->
<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-5335955488392758" data-ad-slot="7121234249"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div>

		<div class="ad hidden-sm visible-xs-block">
			<div id="ezwrap_adsense_responsive_full_1"><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
			<!-- Mobile -->
			<ins class="adsbygoogle" style="display:inline-block;width:320px;height:100px" data-ad-client="ca-pub-5335955488392758" data-ad-slot="7559277795"></ins>
			<script>
				(adsbygoogle = window.adsbygoogle || []).push({});
			</script></div>
		</div>
				
				<div id="post-493824" class="post"><span id="ezoic-pub-ad-placeholder-112" class="ezoic-adpicker-ad"></span><span class="ezoic-ad box-3 box-3112 adtester-container adtester-container-112" data-ez-name="gerweck_net-box-3"><span id="div-gpt-ad-gerweck_net-box-3-0" ezaw="728" ezah="90" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:90px;min-width:728px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-box-3-0')};</script></span></span>
			
		<div class="hero hero--image">
		<div class="hero__copy">
			<h1 class="hero__title">Booker T Discusses WWE Releasing Braun Strowman</h1>
			<div class="hero__meta">
				<p><span class="date">Jun 6, 2021 - by James Walsh </span></p>
			</div>
		</div>
				<div class="hero__caption">Photo Credit: World Wrestling Entertainment</div>
				<img src="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20width%3D%22600%22%20height%3D%22592%22%3E%3C%2Fsvg%3E" class="ezlazyload hero__image" ezimgfmt="ng ngcb1 src" data-ezsrc="https://sf.ezoiccdn.com/ezoimgfmt/www.gerweck.net/wp-content/uploads/2015/12/braun-strowman-19.jpg"/>
	</div>
			
<!-- AddThis Button BEGIN -->
<div class="social-icons">
	<h3 class="text-uppercase">Share It</h3>
	<div class="social">
		<!-- Go to www.addthis.com/dashboard to customize your tools -->
		<div class="addthis_native_toolbox">
		</div>
		<a class="addthis_button_email"> Email</a> <span class="divider"></span> 
		<a href="#commentsContainer" class="comments-link">Comments (2) <span class="icon-chevron-down"></span></a>
	</div>
</div>
<!-- AddThis Button END -->						
				
			<div class="entry">
								
				<p><a href="https://www.gerweck.net/2009/10/24/booker-t/">Booker T</a> spoke on the latest episode of the Hall of Fame Podcast about a wide range of topics.<span id="ezoic-pub-ad-placeholder-125" class="ezoic-adpicker-ad"></span><span class="ezoic-ad medrectangle-3 medrectangle-3125 adtester-container adtester-container-125" data-ez-name="gerweck_net-medrectangle-3"><span id="div-gpt-ad-gerweck_net-medrectangle-3-0" ezaw="728" ezah="90" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:90px;min-width:728px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-medrectangle-3-0')};</script></span></span></p>
<p>Braun Strowman, Aleister Black, Lana, Ruby Riott, Buddy Murphy, and Santana Garrett ended up being released by WWE. During it, he commented on Strowman’s release and the reports about his contract played a factor in the decision.</p>
<p>“It definitely made me go, ‘Wow, Braun Strowman’. Then I started looking at it from a business perspective. If it’s true, the rumors out there are saying Braun Strowman had a huge contract and he’s making a lot of money. If they’re doing budget cuts, that’s the one thing you’re going to be thinking about. Who do we really need? Who’s the guy that we really need here to keep this thing running. Take nothing away from Braun Strowman. He was an enigma. He was a guy that was somewhat of a throwback to the guys that did it once before him. Looking at Braun Strowman, even being the enigma that he was, it was hard to match Braun Strowman up with more than two or three guys on the roster. I can be wrong.</p>
<p><span id="ezoic-pub-ad-placeholder-119" class="ezoic-adpicker-ad"></span><span class="ezoic-ad medrectangle-4 medrectangle-4119 adtester-container adtester-container-119" data-ez-name="gerweck_net-medrectangle-4"><span id="div-gpt-ad-gerweck_net-medrectangle-4-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-medrectangle-4-0')};</script></span></span>There again, he was like a throwback to the way the wrestler was back in the day. The thing is, nothing against him as a wrestler or anything, but just think about it. In Japan back in the day, it was the battle of the giants, the Stan Hansens of the world. The Big Van Vaders of the world. If you look at the layout of Japan now, it’s totally different. The wrestlers are totally different. The way they wrestle now is totally different. That’s the only thing that I’m saying about that right there. Don’t think I’m trying to throw any shade or anything like that. There again, you look at the guys, and you say, ‘Who are the guys that we’re really going to need right now to fuel this thing to take us to the next level and take us to where we want to be.’ Is Braun Strowman one of the guys? Obviously they didn’t think he was one of the guys, or it could have been something underlying that I don’t even know about as far as contract dispute, maybe thinking the grass is greener on the other side, maybe it’s time for me to get up out of here. Maybe it’s one of those types of things. I’m always thinking about a guy like Braun Strowman when he comes around, ‘Man, this is the guy that’s going to replace Kane for the next 20 years. This is the guy that’s going to replace The Undertaker for the next 20 years.’ Think about it. Those days are over. Those days are well behind us. They’re long gone and they will never, ever, come back.”</p>
<p>credit: WrestlingNews.co</p>

				<div class="entry__meta">
					<p><span class="highlight">Post Category:</span> <a href="https://www.gerweck.net/category/news/" rel="category tag">News</a>, <a href="https://www.gerweck.net/category/opinions/" rel="category tag">Opinions</a>     <span class="highlight">Tags:</span> </p>
				</div>

			</div>
			
			<div class="bbm mbl pbl clearfix">
				<div class="col-lg-6 col-md-7 ptl">
					<div class="ad hidden-xs">

					</div>
					<div class="ad hidden-sm visible-xs-block">
						<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
						
					</div>
				</div>
				<div class="col-lg-6 col-md-5 ptl">
					
<div class="wp_rp_wrap  wp_rp_plain" id="wp_rp_first"><div class="wp_rp_content"><h3 class="related_post_title">Related Posts</h3><ul class="related_post wp_rp"><li data-position="0" data-poid="in-319724" data-post-type="none"><a href="https://www.gerweck.net/2017/05/06/impact-wrestling-files-trademark-for-broken-matt-and-other-broken-universe-terms/" class="wp_rp_title">Impact Wrestling Files Trademark For “Broken Matt” And Other Broken Universe Terms</a></li><li data-position="1" data-poid="in-365597" data-post-type="none"><a href="https://www.gerweck.net/2018/08/17/jimmy-jacobs-is-all-in/" class="wp_rp_title">Jimmy Jacobs is ALL IN</a></li><li data-position="2" data-poid="in-246736" data-post-type="none"><a href="https://www.gerweck.net/2015/05/06/damien-sandow-comments-on-fan-reactions-to-his-new-macho-mandow-gimmick/" class="wp_rp_title">Damien Sandow Comments on Fan Reactions to His New “Macho Mandow” Gimmick</a></li><li data-position="3" data-poid="in-96454" data-post-type="none"><a href="https://www.gerweck.net/2012/08/02/more-wwe-conference-news-and-notes/" class="wp_rp_title">More WWE conference News and Notes</a></li><li data-position="4" data-poid="in-388514" data-post-type="none"><a href="https://www.gerweck.net/2019/04/08/wrestlemania-35-takes-3-spot-in-the-biggest-wrestlemania-attendance-chart/" class="wp_rp_title">WrestleMania 35 takes #3 spot in the biggest WrestleMania attendance chart</a></li></ul></div></div>
				</div>
			</div>

					
			<div id="commentsContainer">
				
<!-- You can start editing here. -->

	<h3 id="comments"><span id="ezoic-pub-ad-placeholder-129" class="ezoic-adpicker-ad"></span><span class="ezoic-ad leader-1 leader-1129 adtester-container adtester-container-129" data-ez-name="gerweck_net-leader-1"><span id="div-gpt-ad-gerweck_net-leader-1-0" ezaw="728" ezah="90" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:90px;min-width:728px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-leader-1-0')};</script></span></span>2 Responses</h3>
	<ol class="commentlist">
			<li class="comment even thread-even depth-1" id="comment-404372">
				<div id="div-comment-404372" class="comment-body">
				<div class="comment-author vcard">
						<cite class="fn">Taxx W. Hoodchicken</cite> <span class="says">says:</span>		</div>
		
		<div class="comment-meta commentmetadata">
			<a href="https://www.gerweck.net/2021/06/06/booker-t-discusses-wwe-releasing-braun-strowman/#comment-404372">June 6, 2021 at 10:55 am</a>		</div>

		<p>Book always keep it 100</p>

		
				</div>
				</li><!-- #comment-## -->
		<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-404380">
				<div id="div-comment-404380" class="comment-body">
				<div class="comment-author vcard">
						<cite class="fn">Hans Maulwurf</cite> <span class="says">says:</span>		</div>
		
		<div class="comment-meta commentmetadata">
			<a href="https://www.gerweck.net/2021/06/06/booker-t-discusses-wwe-releasing-braun-strowman/#comment-404380">June 6, 2021 at 2:55 pm</a>		</div>

		<p>Lol… “Budget cuts”… “He earns a lot of money, so it’s understandable”…<br/>
-laughs in Brock Lesnar and OLDberg-<br/>
Not to mention the deal with the terrorists and the Peacock deal.</p>
<p>F*** that cotton picker, he is just kissing WWE’s ass! Seems like they threatened to whip him again.</p>

		
				</div>
				</li><!-- #comment-## -->
	</ol>
	<div class="navigation">
		<div class="alignleft"><span></span></div>
		<div class="alignright"><span></span></div>
	</div>
	

<div id="respond">

<h3 id="respondTitle"><span class="hook">Leave a Reply <span class="cancel-comment-reply"><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/06/06/booker-t-discusses-wwe-releasing-braun-strowman/?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+gerwecknet+%28Gerweck.net%29#respond" style="display:none;">× Cancel reply</a></span></span></h3>


<form action="https://www.gerweck.net/wp-comments-post.php" method="post" id="commentform">


<p class="contain"><input type="text" name="author" id="author" value="" size="22" tabindex="1" aria-required="true"/>
<label for="author"><small>Name (required)</small></label></p>

<p class="contain"><input type="text" name="email" id="email" value="" size="22" tabindex="2" aria-required="true"/>
<label for="email"><small>Mail (required)</small></label></p>

<p class="contain"><input type="text" name="url" id="url" value="" size="22" tabindex="3"/>
<label for="url"><small>Website</small></label></p>

<!--<p><small><strong>XHTML:</strong> You can use these tags: <code><a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> </code></small></p>-->

<p class="contain"><textarea name="comment" id="comment" tabindex="4"></textarea></p>

<input name="submit" type="submit" id="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/>
<input type="hidden" name="comment_post_ID" value="493824" id="comment_post_ID"/>
<input type="hidden" name="comment_parent" id="comment_parent" value="0"/>

<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ba9920b327"/></p><input type="hidden" id="ak_js" name="ak_js" value="14"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea>
</form>


<span id="ezoic-pub-ad-placeholder-118" class="ezoic-adpicker-ad"></span></div>
			</div>

		
				</div>
	</div>
	
	<div class="col-sm-5 col-md-4 sidebar"><span id="ezoic-pub-ad-placeholder-107" class="ezoic-adpicker-ad"></span><span class="ezoic-ad box-1 box-1107 adtester-container adtester-container-107 ezoic-ad-adaptive" data-ez-name="gerweck_net-box-1"><span class="ezoic-ad box-1 box-1-multi-107 adtester-container adtester-container-107" data-ez-name="gerweck_net-box-1"><span id="div-gpt-ad-gerweck_net-box-1-0" ezaw="300" ezah="262" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:262px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-box-1-0')};</script></span></span><span class="ezoic-ad box-1 box-1-multi-107 adtester-container adtester-container-107" data-ez-name="gerweck_net-box-1"><span id="div-gpt-ad-gerweck_net-box-1-0_1" ezaw="300" ezah="262" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:262px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-box-1-0_1')};</script></span></span><span class="ezoic-ad box-1 box-1-multi-107 adtester-container adtester-container-107" data-ez-name="gerweck_net-box-1"><span id="div-gpt-ad-gerweck_net-box-1-0_2" ezaw="300" ezah="262" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:262px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-box-1-0_2')};</script></span></span><span class="ezoic-ad box-1 box-1-multi-107 adtester-container adtester-container-107" data-ez-name="gerweck_net-box-1"><span id="div-gpt-ad-gerweck_net-box-1-0_3" ezaw="300" ezah="262" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:262px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-box-1-0_3')};</script></span></span><style> .box-1-multi-107{border:none !important;display:block !important;float:none;line-height:0px;margin-bottom:2px !important;margin-left:0px !important;margin-right:0px !important;margin-top:2px !important;min-height:250px;min-width:300px;padding:0;text-align:center !important;}</style></span>
		
<div class="hidden-xs">
<form method="get" id="searchform" action="https://www.gerweck.net/" class="search">
	<div class="search__box">
		<input type="text" class="search__input" placeholder="Enter Search Term" value="" name="s" id="s"/>
		<button class="search__btn" type="submit" id="searchsubmit" value="Search"><span class="icon-search"></span></button>
	</div>
</form></div>


<div class="cateogry-feature-box row">
								<div class="col-sm-6">
				<a href="https://www.gerweck.net/fotd/paige-6/"><img src="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20width%3D%22600%22%20height%3D%22800%22%3E%3C%2Fsvg%3E" class="ezlazyload cateogry-feature-box__img" ezimgfmt="ng ngcb1 src" data-ezsrc="https://sf.ezoiccdn.com/ezoimgfmt/www.gerweck.net/wp-content/uploads/2021/04/paige-050421.jpg"/></a>
			</div>
			<div class="col-sm-6">
				<h3 class="h4">Female of the Day</h3>
				<h4 class="cateogry-feature-box__title">Paige</h4>
				<a href="https://www.gerweck.net/fotd/paige-6/" class="cateogry-feature-box__link">view pictures</a>
				<hr/>
				<a href="/fotd/">View All</a>
			</div>
				</div>


<div class="paypal-callout bb bt clearfix pvl mvl">
	<div class="col-sm-8">
		<h3 class="paypal-callout__copy">Love what you&#39;re reading? Help support GERWECK.net</h3>
	</div>
	<div class="col-sm-4">
		<a class="paypal-callout__link" href="https://www.paypal.me/SteveGerweck">DONATE <span>with <span class="paypal-icon">Paypal</span></span></a>
	</div>
</div>

<div class="overflow">
	<div class="sponsors">
				
									<div class="col-xs-6">
				<div class="prs">
					<p><a href="https://www.gerweck.net/2021/04/30/gerweck-net-supporting-melissa-coates-and-you-can-too/"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20width%3D%22150%22%20height%3D%22150%22%3E%3C%2Fsvg%3E" width="145" height="145" ezimgfmt="ng ngcb1 src" class="ezlazyload" data-ezsrc="https://sf.ezoiccdn.com/ezoimgfmt/www.gerweck.net/wp-content/uploads/2021/05/temp2.jpg"/></a> </p>
				</div>
			</div>
								<div class="col-xs-6">
				<div class="pls">
					<p><a href="https://affiliates.audiobooks.com/tracking/scripts/click.php?a_aid=5f415fa5b9918&amp;a_bid=33e70d85"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20width%3D%22150%22%20height%3D%22150%22%3E%3C%2Fsvg%3E" width="145" height="145" class="ezlazyload alignleft size-full wp-image-281398" ezimgfmt="ng ngcb1 src" data-ezsrc="https://sf.ezoiccdn.com/ezoimgfmt/www.gerweck.net/wp-content/uploads/2020/11/abc1.jpg"/></a> </p>
				</div>
			</div>
								<div class="col-xs-6">
				<div class="pls">
					<p><a href="http://www.gerweck.net/category/interviews/" target="_new" rel="noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20width%3D%22150%22%20height%3D%22150%22%3E%3C%2Fsvg%3E" border="0" width="145" height="145" ezimgfmt="ng ngcb1 src" class="ezlazyload" data-ezsrc="https://sf.ezoiccdn.com/ezoimgfmt/www.gerweck.net/wp-content/uploads/2020/12/mic.jpg"/></a></p>
				</div>
			</div>
								<div class="col-xs-6">
				<div class="pls">
					<p><a href="http://www.prowrestlingtees.com/gerweck"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%20width%3D%22150%22%20height%3D%22150%22%3E%3C%2Fsvg%3E" width="145" height="145" class="ezlazyload alignleft size-full wp-image-281398" ezimgfmt="ng ngcb1 src" data-ezsrc="https://sf.ezoiccdn.com/ezoimgfmt/www.gerweck.net/wp-content/uploads/2020/11/4.jpg"/></a></p>
				</div>
			</div>
					
			</div>
</div>
<div class="ad mvl text-center hidden-sm hidden-xs">
<!-- Conversant Media 300x600 Half Page CODE for Gerweck.Net -->
<script type="text/javascript">var vclk_options = {sid:25111,media_id:8,media_type:10,version:"1.4"};</script><div id="ezwrap_value_click_0"><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=25111&amp;media_id=8&amp;media_type=10&amp;version=1.4&amp;exc=1"></script></div><noscript><a href="http://media.fastclick.net/w/click.here?sid=25111&m=8&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=25111&m=8&tp=10&d=s&c=1&vcm_acv=1.4" width="300" height="600" border="1"></a></noscript>
<!-- Conversant Media 300x600 Half Page CODE for Gerweck.Net -->

</div>

<div class="ad mbl text-center hidden-sm hidden-xs">
	<div id="ezwrap_adsense_responsive_full_2"><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<!-- LS -->
	<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-5335955488392758" data-ad-slot="3785466192"></ins>
	<script>
	(adsbygoogle = window.adsbygoogle || []).push({});
	</script></div>
</div>

<div class="ad hidden-sm visible-xs-block">
	<div id="ezwrap_greystripe_0"><script type="text/javascript">
		 var gsad = {
		    site_id : 25111, 
		    sizes : ["300x250"]
		 };
	 </script>
	 <script type="text/javascript" src="http://c.greystripe.com/gsswf/ad.js"></script></div>
</div>

<div class="ad hidden-sm visible-xs-block">
	 <div id="ezwrap_greystripe_1"><script type="text/javascript">
		 var gsad = {
		    site_id : 25111, 
		    sizes : ["320x50"]
		 };
	 </script>
	 <script type="text/javascript" src="http://c.greystripe.com/gsswf/ad.js"></script></div>
</div>

<div class="ad mbl text-center"><span id="ezoic-pub-ad-placeholder-116" class="ezoic-adpicker-ad"></span><span class="ezoic-ad large-leaderboard-1 large-leaderboard-1116 adtester-container adtester-container-116 ezoic-ad-adaptive" data-ez-name="gerweck_net-large-leaderboard-1"><span class="ezoic-ad large-leaderboard-1 large-leaderboard-1-multi-116 adtester-container adtester-container-116" data-ez-name="gerweck_net-large-leaderboard-1"><span id="div-gpt-ad-gerweck_net-large-leaderboard-1-0" ezaw="300" ezah="262" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:262px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-large-leaderboard-1-0')};</script></span></span><span class="ezoic-ad large-leaderboard-1 large-leaderboard-1-multi-116 adtester-container adtester-container-116" data-ez-name="gerweck_net-large-leaderboard-1"><span id="div-gpt-ad-gerweck_net-large-leaderboard-1-0_1" ezaw="300" ezah="262" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:262px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-large-leaderboard-1-0_1')};</script></span></span><span class="ezoic-ad large-leaderboard-1 large-leaderboard-1-multi-116 adtester-container adtester-container-116" data-ez-name="gerweck_net-large-leaderboard-1"><span id="div-gpt-ad-gerweck_net-large-leaderboard-1-0_2" ezaw="300" ezah="262" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:262px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-large-leaderboard-1-0_2')};</script></span></span><span class="ezoic-ad large-leaderboard-1 large-leaderboard-1-multi-116 adtester-container adtester-container-116" data-ez-name="gerweck_net-large-leaderboard-1"><span id="div-gpt-ad-gerweck_net-large-leaderboard-1-0_3" ezaw="300" ezah="262" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:262px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-large-leaderboard-1-0_3')};</script></span></span><style> .large-leaderboard-1-multi-116{border:none !important;display:block !important;float:none;line-height:0px;margin-bottom:2px !important;margin-left:0px !important;margin-right:0px !important;margin-top:2px !important;min-height:250px;min-width:300px;padding:0;text-align:center !important;}</style></span>
	<!-- Conversant Media 180x150 Rectangle CODE for Gerweck.Net -->
	<script type="text/javascript">var vclk_options = {sid:25111,media_id:7,media_type:9,version:"1.4"};</script><div id="ezwrap_value_click_1"><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=25111&amp;media_id=7&amp;media_type=9&amp;version=1.4&amp;exc=1"></script></div><noscript><a href="http://media.fastclick.net/w/click.here?sid=25111&m=7&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=25111&m=7&tp=9&d=s&c=1&vcm_acv=1.4" width="180" height="150" border="1"></a></noscript>
	<!-- Conversant Media 180x150 Rectangle CODE for Gerweck.Net -->
</div>	<span id="ezoic-pub-ad-placeholder-148" class="ezoic-adpicker-ad"></span><span class="ezoic-ad banner-2 banner-2148 adtester-container adtester-container-148 ez-sticky" data-ez-name="gerweck_net-banner-2"><span id="div-gpt-ad-gerweck_net-banner-2-0" ezaw="336" ezah="280" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:280px;min-width:336px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-banner-2-0')};</script></span><span style="width:336px;display:block;height:14px;margin:auto" class="reportline"><span style="text-align:center;font-size: smaller;float:left;line-height:normal;"><a href="https://www.ezoic.com/what-is-ezoic/" target="_blank" rel="noopener noreferrer nofollow" style="cursor:pointer"><img src="https://go.ezoic.net/utilcave_com/img/ezoic.png" alt="Ezoic" style="height:12px !important; padding:2px !important; border:0px !important; cursor:pointer !important; width: 58px !important; margin:0 !important; box-sizing: content-box !important;"/></a></span><span class="ez-report-ad-button" name="?pageview_id=94391528-f9ce-4f28-7c56-cee5025221d4&amp;ad_position_id=148&amp;impression_group_id=gerweck_net-banner-2/2021-06-07/1079236&amp;ad_size=336x280&amp;domain_id=81851&amp;url=https://www.gerweck.net/2021/06/06/booker-t-discusses-wwe-releasing-braun-strowman/" style="cursor: pointer!important; font-size:12px !important;color: #a5a5a5 ;float:right;text-decoration:none !important;font-family:arial !important;line-height:normal;">report this ad</span></span></span></div>
</div>


</div> <!-- End content div -->

<footer class="footer container">
	<div class="row">
		<div class="col-md-8 col-sm-7">	
			<p class="copyright">©1997-2021 gerweck.net LLC. All Rights Reserved This site is in no way affiliated with any wrestling promotions including WWE and TNA. All pictures and media files are copyrighted by their respective owners. No portion of this site may be used without the consent of Steve Gerweck.</p>
		</div>
		<div class="col-md-4 col-sm-5">
			<a href="/contact-us">Contact</a>  |  <a href="/privacy-policy">Privacy Policy</a>  |  <a href="/opinion-disclaimer">Opinion Disclaimer</a>
		</div>
	</div>
</footer>

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js"></script>
<script>window.jQuery || document.write('<script src="https://www.gerweck.net/wp-content/themes/gerweckv4/js/vendor/jquery-1.9.1.min.js"><\/script>')</script>
<script type="text/javascript" src="https://www.gerweck.net/wp-content/themes/gerweckv4/js/vendor/jquery.flexslider.js"></script>

<!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4e343aec6c6e3b1e"></script>

<script type="text/javascript" src="https://www.gerweck.net/wp-content/themes/gerweckv4/js/core.js"></script>


<!-- Infolinks START -->
<script type="text/javascript">jQuery(document).ready(function(){jQuery('.description').before('<span><!--INFOLINKS_OFF--></span>');jQuery('.description').after('<span><!--INFOLINKS_ON--></span>');jQuery('#headerimg').before('<span><!--INFOLINKS_OFF--></span>');jQuery('#headerimg').after('<span><!--INFOLINKS_ON--></span>');jQuery('h1').before('<span><!--INFOLINKS_OFF--></span>');jQuery('h1').after('<span><!--INFOLINKS_ON--></span>');jQuery('h1').before('<span><!--INFOLINKS_OFF--></span>');jQuery('h1').after('<span><!--INFOLINKS_ON--></span>');});</script>

<div id="ezwrap_info_links-2_0"></div>
<!-- Infolinks END --><script type="text/javascript" src="https://c0.wp.com/c/5.7.2/wp-includes/js/comment-reply.min.js" id="comment-reply-js"></script>
<script type="text/javascript" id="wp-polls-js-extra">
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.gerweck.net\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.gerweck.net/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.6" id="wp-polls-js"></script>
<script type="text/javascript" src="https://c0.wp.com/c/5.7.2/wp-includes/js/wp-embed.min.js" id="wp-embed-js"></script>
<script async="async" type="text/javascript" src="https://www.gerweck.net/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9" id="akismet-form-js"></script>
<script src="https://stats.wp.com/e-202123.js" defer=""></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.8',blog:'113675970',post:'493824',tz:'-4',srv:'www.gerweck.net'} ]);
	_stq.push([ 'clickTrackerInit', '113675970', '493824' ]);
</script>


<!--[selectrongo:done]--><div class="ezmob-footer ezoic-floating-bottom ezo_ad ezmob-footer-desktop" id="ezmobfooter"><center><span id="ezoic-pub-ad-placeholder-100"></span><div class="ezmob-footer ezoic-floating-bottom ezo_ad ezmob-footer-desktop" id="ezmobfooter"><center><span class="ezoic-ad medrectangle-2 medrectangle-2100 adtester-container adtester-container-100" data-ez-name="gerweck_net-medrectangle-2"><span id="div-gpt-ad-gerweck_net-medrectangle-2-0" ezaw="728" ezah="90" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:90px;min-width:728px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-gerweck_net-medrectangle-2-0')};</script></span></span></center><span class="ezmob-footer-close" onclick="document.getElementById(&#39;ezmobfooter&#39;).style.display=&#39;none&#39;;">x</span></div></center><span class="ezmob-footer-close" onclick="document.getElementById(&#39;ezmobfooter&#39;).style.display=&#39;none&#39;;">x</span></div><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer="">try{var __ezlcp;const fd=window._ezfd||{}
fd.measure=fd.measure||function(cb){cb()}
function __ezlcpcd(){fd.measure(function(){const po=new PerformanceObserver((entryList)=>{const entries=entryList.getEntries();const lcpElement=entries[entries.length-1];var vh=window.innerHeight||Math.max(document.documentElement.clientHeight,document.body.clientHeight);var scrollTop=window.pageYOffset||document.documentElement.scrollTop;if(lcpElement.element.getBoundingClientRect().top+scrollTop<vh){if(lcpElement!=undefined&&lcpElement.element.parentElement!=undefined&&lcpElement.element.parentElement.id=="ez-cookie-template"){return;}
__ezlcp=lcpElement;}});po.observe({type:'largest-contentful-paint',buffered:true});});};__ezlcpcd();function __ez_sendLCPElement(){fd.measure(function(){if(window.__ezlcp&&typeof window.__ezlcp.element!='undefined'&&window._ezaq&&typeof window._ezaq.domain_id=='undefined'){var vh=window.innerHeight||Math.max(document.documentElement.clientHeight,document.body.clientHeight);var json={url:document.URL,formfactor:window.ezoFormfactor,domainid:window._ezaq.domain_id,element:__ezlcp.element.outerHTML,viewht:vh,};var url="/cheetah/lcpel.go";if((typeof window.ezJsu!=="undefined"&&window.ezJsu===true)||(typeof window._ez_sa!=="undefined"&&window._ez_sa===true)||((typeof window.isAmp!='undefined')&&window.isAmp===true)||((typeof window.ezWp!=='undefined')&&window.ezWp===true)){url="//g.ezoic.net"+url;}
var xhr=new XMLHttpRequest();xhr.open("POST",url,true);xhr.setRequestHeader('Content-Type','text/plain');xhr.send(JSON.stringify(json));}else{setTimeout(__ez_sendLCPElement,4000);}});}
if(window.addEventListener){window.addEventListener('load',function(){setTimeout(__ez_sendLCPElement,2000);},false);}}catch(e){}</script><script>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</script>
<script>var __ez_tkn_evnt = function() { if(typeof(_ezaq) != 'undefined'){if(typeof window.ezogtk !== "undefined" && window.ezogtk !== "") {__ez.bit.AddAndFire(_ezaq.page_view_id,[new __ezDotData("ext_user_hash",window.ezogtk)]);}}};document.addEventListener("DOMContentLoaded", __ez.queue.addFunc("__ez_tkn_evnt", "__ez_tkn_evnt", event, false, ['/detroitchicago/minneapolis.js','/detroitchicago/memphis.js'], true, true, false, true));</script>
<script async data-ezscrex="false">__ez_fad_load(0,0);__ez_fad_doc_ht=__ez_fad_docht();__ez_fad_vp_ht=__ez_fad_vpht();function __ez_fad_scroll(){return window.pageYOffset||(document.documentElement||document.body.parentNode||document.body).scrollTop}
var __ez_fad_scrollint=setInterval(function(){var sy=__ez_fad_scroll();var isShortPage=__ez_fad_doc_ht<=(__ez_fad_vh+100);var bot=(__ez_fad_vp_ht+sy);var botThresh=bot+__ez_fad_vp_ht;for(var divid in __ez_fad_divpos){if(__ez_fad_fastdiv.indexOf(divid)!=-1){continue;}
var divPos=__ez_fad_divpos[divid];if(divPos>0&&divPos>sy&&divPos<(sy+200)){if(typeof __ez_fad_instaslots[divid]=='function'){__ez_fad_instaslots[divid]();}}else if(divPos>0&&divPos>sy&&divPos<(sy+600)){if(typeof __ez_fad_instaslots[divid]=='function'){__ez_fad_viewslots[divid]();}}}
__ez_fad_chkpos();if(ezslit_run[0]!=true){__ez_fad_load(0,0);}
if((sy>0||isShortPage)&&ezslit_run[1]!=true){__ez_fad_load(1,null);__ez_fad_load(5,null);}
if((sy>100||isShortPage)&&ezslit_run[2]!=true){__ez_fad_load(2,null);}
if(sy>(__ez_fad_vp_ht*.75)&&ezslit_run[3]!=true){__ez_fad_load(3,null);}
if(ezslit_run[1]==true&&ezslit_run[2]==true&&ezslit_run[3]==true){clearInterval(__ez_fad_scrollint);}},500);function __ez_fad_chkpos(){if(typeof __ez_fad_divs[4]!='undefined'){for(var i=0;i<__ez_fad_divs[4].length;i++){var id=__ez_fad_divs[4][i];__ez_fad_divs[4][i]=null;__ez_fad_position([id]);};}}</script>
<script type="text/javascript">(function(f,a){function g(b,a,c){b.addEventListener?b.addEventListener(a,c):b.attachEvent("on"+a,function(){c.call(b)})}function k(b){b&&("string"==typeof b["class"]&&b["class"]&&a.getElementById("uglipop_popbox").setAttribute("class",b["class"]),b.keepLayout&&!b["class"]&&a.getElementById("uglipop_popbox").setAttribute("style","position:relative;height:300px;width:300px;background-color:white;opacity:1;"),"string"==typeof b.content&&b.content&&"html"==b.source&&(a.getElementById("uglipop_popbox").innerHTML=b.content),"string"==typeof b.content&&b.content&&"div"==b.source&&(a.getElementById("uglipop_popbox").innerHTML=a.getElementById(b.content).innerHTML));a.getElementById("uglipop_overlay_wrapper").style.display="";a.getElementById("uglipop_overlay").style.display="";a.getElementById("uglipop_content_fixed").style.display=""}function h(){a.getElementById("uglipop_overlay_wrapper").style.display="none";a.getElementById("uglipop_overlay").style.display="none";a.getElementById("uglipop_content_fixed").style.display="none"}g(a,"DOMContentLoaded",function(){var b=a.createElement("div"),e=a.createElement("div"),c=a.createElement("div"),d=a.createElement("div");e.id="uglipop_content_fixed";e.setAttribute("style","position:fixed;top: 50%;left: 50%;transform: translate(-50%, -50%);-webkit-transform: translate(-50%, -50%);-ms-transform: translate(-50%, -50%);opacity:1;z-index:10000000;");c.id="uglipop_popbox";d.id="uglipop_overlay_wrapper";d.setAttribute("style","position:absolute;top:0;bottom:0;left:0;right:0;display:none");b.id="uglipop_overlay";b.setAttribute("style","position:fixed;top:0;bottom:0;left:0;right:0;opacity:0.3;width:100%;height:100%;background-color:black;");d.appendChild(b);e.appendChild(c);a.body.appendChild(d);a.body.appendChild(e);a.getElementById("uglipop_overlay_wrapper").style.display="none";a.getElementById("uglipop_overlay").style.display="none";a.getElementById("uglipop_content_fixed").style.display="none";d.addEventListener("click",h);g(f,"keydown",function(a){27==a.keyCode&&h()});f.uglipop=k})})(window,document);var ezRBA=(function(){function init(){var reportAdsBtns=document.querySelectorAll('.ez-report-ad-button');for(var i=0;i<reportAdsBtns.length;i++){reportAdsBtns[i].addEventListener('click',function(e){var url='<iframe src="https://svc.ezoic.com/pub/reportads/reportads.html'+e.target.getAttribute('name')+'" width="400" height="500" style="border-radius: 10px; box-shadow: 2px 2px 30px 6px rgba(0,0,0,0.75); border: 1px solid black;"></iframe>'
uglipop({class:'none',source:'html',content:url,});});}
function bindEvent(element,eventName,eventHandler){if(element.addEventListener){element.addEventListener(eventName,eventHandler,false);}else if(element.attachEvent){element.attachEvent('on'+eventName,eventHandler);}}
bindEvent(window,'message',function(e){if(e.data==='close-report-ad-modal'){document.getElementById('uglipop_overlay_wrapper').style.display='none';document.getElementById('uglipop_overlay').style.display='none';document.getElementById('uglipop_content_fixed').style.display='none';}})}
return{init:init};})();ezRBA.init();</script>
<script type="text/javascript" data-cfasync="false">(function(){var addListeners=function(eltype,els){for(var en=0;en<els.length;en++){var el=els[en];if(el.complete==false||(typeof(el.readyState)!='undefined'&&el.readyState<4)){var src=el.getAttribute('src')||el.currentSrc;if(typeof(el.readyState)!='undefined'&&el.readyState==0){el.addEventListener('loadstart',function(e){var src=e.currentTarget.getAttribute('src')||e.currentSrc;window["ezorqs"](e,src);});}else{var src=el.getAttribute('src')||el.currentSrc;window["ezorqs"](el,src);}
el.addEventListener('load',function(e){var src=e.currentTarget.getAttribute('src')||e.srcElement.currentSrc;window["ezorqe"](e,src);});el.addEventListener('loadeddata',function(e){var src=e.currentTarget.getAttribute('src')||e.srcElement.currentSrc;window["ezorqe"](e,src);});el.addEventListener('error',function(e){var src=e.currentTarget.getAttribute('src')||e.srcElement.currentSrc;window["ezorqe"](e,src);});}}};var CssLoadedListeners=function(els){for(var en=0;en<els.length;en++){var el=els[en];if((el.getAttribute('rel')=='preload'||el.getAttribute('rel')=='stylesheet')&&el.getAttribute('href')!=null){if(isStyleSheetLoaded(el.getAttribute('href'))){window["ezorqs"](el,el.getAttribute('href'));var img=document.createElement('img');img.onerror=function(e){if(typeof e.path!="undefined"&&typeof e.path[0].currentSrc!="undefined"){window["ezorqe"](el,e.path[0].currentSrc);}else if(typeof e.srcElement!="undefined"&&typeof e.srcElement.href!="undefined"){window["ezorqe"](el,e.srcElement.href);}};img.src=el.getAttribute('href');}else{}}else{}}};function isStyleSheetLoaded(url){for(var i=0;i<document.styleSheets.length;i++){if(document.styleSheets[i].href==url){return true}}
return false;}
__ez_addAllListeners=function(){addListeners('img',document.querySelectorAll('img'));addListeners('video',document.querySelectorAll('video'));addListeners('audio',document.querySelectorAll('audio'));CssLoadedListeners(document.querySelectorAll('link'));if(typeof window["__ez"]["ssaf"]!="undefined"&&window["__ez"]["ssaf"].indexOf(16)>-1){if(typeof window["__ez"]["sshsdef"]!=="undefined"&&window["__ez"]["sshsdef"]===false){if(Element.prototype.addEventListener){if(typeof window["onload"]=="function"){window["addEventListener"]("load",window["onload"]);window["onload"]=null;}
if(typeof document["onload"]=="function"){document["addEventListener"].addEventListener("load",document["onload"]);document["onload"]=null;}}}}}
__ez.queue.addFunc("__ez_addAllListeners","__ez_addAllListeners",null,false,['/detroitchicago/tulsa.js'],true,true,true,true);}());</script>
<script type="text/javascript" style='display:none;'>var __ez_dims = (function() {
		var setCookie = function( name, content, expiry ) {
			return document.cookie = name+'='+content+((expiry)?';expires='+(new Date(Math.floor(new Date().getTime()+expiry*1000)).toUTCString()):'')+';path=/';
		};
		var ffid = 1;
		var oh = window.screen.height;
		var ow = window.screen.width;
		var h = ffid === 1 ? oh : (oh > ow) ? oh : ow;
		var w = ffid === 1 ? ow : (oh > ow) ? ow : oh;
		var uh = window.innerHeight || document.documentElement.clientHeight || document.getElementsByTagName('body')[0].clientHeight;
		var uw = window.innerWidth || document.documentElement.clientWidth || document.getElementsByTagName('body')[0].clientWidth;
		setCookie('ezds', encodeURIComponent('ffid='+ffid+',w='+w+',h='+h), (31536e3*7));
		setCookie('ezohw', encodeURIComponent('w='+uw+',h='+uh), (31536e3*7));
	})();</script><script type='text/javascript' style='display:none;' async>
</script>
</body></html>